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1. Introduction 

 

PowerPoint 2010 is presentation software that allows you to create dynamic slide 

presentations that can include animation, narration, images, and videos. 

 

2. Getting to know PowerPoint 2010 

 

If you are familiar with PowerPoint 2007, you'll notice that there aren't too many 

changes to the 2010 interface other than Backstage view, 

 

3. Navigating PowerPoint to create a slide presentation 

 

PowerPoint uses slides to build a presentation. To create an engaging presentation, 

PowerPoint allows you to add text, bulleted lists, images, charts, and video to your 

slides. You can add as many slides as you want to a presentation, and at any time you 

can view or play back your presentation by selecting one of the slide show play options. 

 

4. Working with your PowerPoint environment 

 

The Ribbon and Quick Access toolbar are where you will find the commands you need 

to perform common tasks in PowerPoint. If you are familiar with PowerPoint 2007, you 

will find that the main difference in the PowerPoint 2010 Ribbon is that commands such 

as Open and Print are now housed in Backstage view. 
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5. Slide basics 

 

Every PowerPoint presentation is composed of a series of slides. To begin creating a slide 

show, you'll need to know the basics of working with slides. You'll need to feel 

comfortable with tasks such as inserting a new slide, changing the layout of a 

slide, arranging existing slides, changing slide view, and adding notes to a slide. 

 

About slides 

 

Slides contain placeholders, which are areas on the slide that are enclosed by dotted 

borders. Placeholders can contain many different items, including text, pictures, and 

charts. Some placeholders have placeholder text, or text you can replace. They also 

have thumbnail-sized icons that represent specific commands such as Insert Picture, Insert 

Chart, and Insert ClipArt. In PowerPoint, hover over each icon to see the type of content 

you can insert in a placeholder. 

 

 

 

About slide layouts 

 

Placeholders are arranged in different layouts that can be applied to existing slides or 

chosen when you insert a new slide. A slide layout arranges your content using different 

types of placeholders, depending on what information you might want to include in 

your presentation. In the figure above, the layout is called Title and Content and includes 

title and content placeholders. While each layout has a descriptive name, you can also 

tell from the image of the layout how the placeholders will be arranged. 
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To use a blank slide: 

 

For more control over your content, you may prefer a blank slide—a slide without 

placeholders—over one of the existing layouts. Blank slides can be customized by adding 

your own text boxes, pictures, charts, and more. 

 Select Blank from the menu of layout options, from the Home tab, Slides group. 

 

 

 

Working with slides 

 

To insert a new slide: 

1. From the Home tab, Slides group, click the bottom half of the New 

Slide command to open the menu of slide layout options. 
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2. Select the slide you want to insert. 

 

 

 

3. A new slide will be added your presentation. 

 

 

To delete a slide: 

 

1. Select the slide you want to delete. 

2. Press the Delete or Backspace key on your keyboard. 

 

To copy and paste a slide: 

 

1. On the Slides tab in the left pane, select the slide you want to copy. 

2. Click the Copy command on the Home tab. You can also right-click your selection 

and choose Copy. 

3. In the left pane, click just below a slide—or between two slides—to choose the 

location where you want the copy to appear. A horizontal insertion point will 

mark the location. 
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4. Click the Paste command on the Home tab. You can also right-click and 

choose Paste. The copied slide will appear. 

 

To duplicate a slide: 

 

An alternative to copying and pasting, duplicating slides copies the selected slide and—in 

one step—pastes it directly underneath. This feature does not allow you to choose the 

location of the copied slide, nor does it offer Paste Options for advanced users, so it's 

more convenient for quickly inserting similar slides. 

 

1. Select the slide you want to duplicate. 

2. Click the New Slide command. 

3. Choose Duplicate Selected Slides from the drop-down menu. 
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4. A copy of the selected slide appears underneath the original. 
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6. Themes 

 

A theme is a set of colors, fonts, effects, and more that can be applied to your entire 

presentation to give it a consistent, professional look. You've already been using a theme, 

even if you didn't know it: the default Office theme, which consists of a white 

background, the Calibri font, and primarily black text. Themes can be applied or changed 

at any time. 

 

Applying themes 

 

You will need to know how to apply a theme and how to switch to a different theme if 

you want to use this feature to create presentations. All of the themes included in 

PowerPoint are located in the Themes group on the Design tab. Themes can be applied 

or changed at any time. 

 

To apply a theme: 

 

1. Go to the Design tab. 

2. Locate the Themes group. Each image represents a theme. 

 

 

 

3. Click the drop-down arrow to access more themes. 

Offline Topics: PowerPoint offers a variety of views and tools to help you organize 

and prepare your slide show. Watch Video 23- About Slide Views. 

 

 

 



Al-Balqa Applied University- Computer Science Department. 

Followed Computer Skills Course-Chapter 6 

 

Page 9 of 18 
 

 

 

 

 

4. Hover over a theme to see a live preview of it in the presentation. The name of 

the theme will appear as you hover over it. 

 

 

 

 

5. Click a theme to apply it to the slides. 

 

7. Applying transitions 

 

Transitions are motion effects that when in Slide Show view add movement to your 

slides as you advance from one slide to another. There are many transitions to choose 

from, each one of which allows you to control the speed and even add sound. A 

transition can be as simple as fading to the next slide or as complex as a flashy, eye-

catching effect. This means you can choose transitions to fit the style of any presentation. 
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About transitions 

 

There are three categories of unique transitions to choose from, all of which can be 

found on the Transitions tab: 

 

 Subtle (slight transitions) 

 

 

 

 Exciting (strong transitions) 

 

 

 

 Dynamic Content (strong transitions that affect only the content, such as text or 

images) 

 

 

 

To apply a transition: 

1. Select the slide you want to modify. 

2. Click the Transitions tab. 

3. Locate the Transition to This Slide group. By default, None is applied to each 

slide. 
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4. Click the More drop-down arrow to display all of the transitions. 

5. Click a transition to apply it to the selected slide. This will automatically preview 

the transition as well. 

 

To preview a transition: 

You can preview the transition for a selected slide at any time, using either of these two 

methods: 

 Click the Preview command on the Transitions tab. 

 

  

 

 Click the star Play Animations icon. The icon appears on the Slides tab in the left 

pane beside any slide that includes a transition. 
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Modifying transitions 

To modify the duration: 

1. Select the slide that includes the transition you want to modify. 

2. In the Duration field in the Timing group, enter the amount of time you want the 

transition to take. In this example, we will specify the length as 2 seconds, or 

02.00. 

 

 

 

To add sound: 

1. Select the slide that includes the transition you want to modify. 

2. Click the Sound drop-down menu in the Timing group. 

3. You will hear the sound and see a live preview of the transition as you hover over 

each sound. 

 

 

 

4. Click a sound to apply it to the selected slide. 

 

To remove a transition: 

1. Select the slide you want to modify. 

2. Choose None from the gallery in the Transition to This Slide group. 
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3. Repeat this process for each slide you want to modify. 

 

8. Animating text and objects 

 

PowerPoint offers a variety of animations you can use to enhance your presentation. 

Animations can be used to make text or objects appear on a slide, exit a slide, 

or emphasize the text or objects already on a slide. You can even use motion paths to 

create a customized animation. 

 

The four types of animations 

There are many different animation effects, you can choose from, and they are organized 

into four types: 

 Entrance: These control how the object enters the slide. For example, with 

the Bounce animation, the object will drop onto the slide and then bounce several 

times. 

 

 

 Emphasis: These animations occur while the object is on the slide and are often 

triggered by a mouse click. For example, you can set an object to Spin when you 

click the mouse. 

 

 

 Exit: These control how the object exits the slide. For example, with 

the Fade animation, the object will simply fade away. 

 

 

 Motion Paths: These are similar to Emphasis effects, except the object moves 

within the slide along a predetermined path, like a circle. 
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To apply an animation to an object: 

1. Select an object. 

2. Click the Animations tab. 

3. In the Animation group, click the More drop-down arrow to view the available 

animations. 

 

 

 

4. Select the desired animation effect. 

 

 

 

5. The object will now have a small number next to it to show that it has an 

animation. Also, in the Slide pane, the slide will now have a star symbol next to it. 
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At the bottom of the menu, you can access even more effects. 

  

 

 

The Animation pane 

The Animation pane allows you to view and manage all of the effects that are on the 

current slide. You can modify and reorder effects directly from the Animation pane, 

which is especially useful when you have several effects. 

To open the Animation pane: 

1. From the Animations tab, click the Animation Pane command. 
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2. The Animation pane will open on the right side of the window. It will show all of 

the effects for the current slide in the order they will appear. 

 

 

 

To reorder effects from the Animation pane: 

 

1. On the Animation pane, click and drag an effect up or down. 

 

 

 

2. The effects will reorder. 

 

To preview effects from the Animation pane: 

 

1. From the Animation pane, click the Play button. 
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2. The effects for the current slide will play. On the right side of the Animation pane, 

you will be able to see a timeline that shows the progress through each effect. 

 

 

 

9. Presenting a slide show 

 

To present your slide show, you'll need to know how to start it. PowerPoint allows you 

to start your slide show from the first slide or from any slide within the slide show. Once 

your slide show has started, you'll need to know how to advance through the slides. 

 

To start a slide show: 

 

1. Select the Slide Show tab. 

2. Click the “From Beginning” command in the Start Slide Show group to start the 

slide show with the first slide. 
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Offline Topics: How to insert video and audio directly into your presentation can be 

found in Video 24- Insert Video and Audio into PowerPoint Presentation 2010. 

 

 

 


